PhotoQt v1.5.1 is available

Even though PhotoQt v1.5 is only a few days old, I have heard from some users about some difficulties they had in getting the required dependency QtCharts installed. It appears that this QML module is not shipped by all distributions as it's a rather new module (even though it doesn't state this on the respective documentation page). This issue is addressed with this release.

The module QtCharts was only used by one element: the one responsible for drawing the histogram. However, I only needed some very basic features of this module, so I sat down and developed a custom drawing implementation that does the same thing I need without requiring this dependency. I now use a simple Image element with a special image loader that creates the required histogram at the required size. I was also able to streamline a few things, so that it should even be a little bit faster now, in particular when switching between the colour and greyscale version.

The QtCharts module was the main dependency I was trying to replace. However, this caused me to take a closer look at all the modules imported in the QML source files. As it turns out, the modules QtQuick.Window and QtQuick.Dialogs are both imported in a few files, but not used anywhere anymore. Thus it was enough to remove all the respective import statements for these two modules in order to eliminate another two dependencies.

Other than these two changes (one big one, one small one), there hasn't really been anything new in v1.5.1. However, my hope is that this release can now be available for anyone on any platforms.

If you have any thoughts, feedback, comments, or if you find a bug, please don't hesitate to let me know: (you need to enable javascript to see the email address)

Enjoy PhotoQt :-)




Join the discussion

Your email address will not be published. Required fields are marked *